Skip to main content
VulnerabilityPublished

CVE-2025-69233: Apache CloudStack · Time-of-check Time-of-use (TOCTOU) Race Condition

Affects Apache CloudStackSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium.

Data as of 30 Oct 2026, 11:34 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache CloudStackAffected
  • >=4.0.0 <=4.20.2.0
  • >=4.21.0.0 <=4.22.0.0
Fixed in–
Mavenorg.apache.cloudstack/cloudstackpkg:maven/org.apache.cloudstack/cloudstackOther threatsAffected
  • =4.0.0
  • =4.21.0.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade to Apache CloudStack versions 4.20.3.0 or 4.22.0.1 or later, as these versions contain fixes for this vulnerability. Patch status is not explicitly stated beyond these recommended versions; therefore, confirm with the vendor advisory for the latest remediation guidance. No other mitigations are specified.

Description

Due to multiple time-of-check time-of-use race conditions in the resource count check and increment logic, as well as missing validations, users of the platform are able to exceed the allocation limits configured for their accounts/domains. This can be used by an attacker to degrade the infrastructure's resources and lead to denial of service conditions. Users are recommended to upgrade to Apache CloudStack versions 4.20.3.0 or 4.22.0.1, or later, which fixes this issue.

References

Community reviews

Loading reviews…