Skip to main content
VulnerabilityPublished Updated

CVE-2025-69633: Advanced Popup Creator · A SQL Injection

Source CVE Database V5

0

Not known to be exploited · CVSS 9.8 Critical · fixed in 1.2.7 : patch affected systems as a priority.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.2.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

AI-suggested

To mitigate CVE-2025-69633, organizations should immediately upgrade the Advanced Popup Creator module to version 1.2.7 or later, which contains the security fix. If upgrading is not immediately possible, implement web application firewall (WAF) rules to detect and block suspicious SQL injection patterns targeting the fromController parameter. Conduct thorough input validation and sanitization on all user-supplied parameters at the application level. Employ parameterized queries or prepared statements in custom code interacting with the module to prevent injection. Regularly audit and monitor database logs for unusual query activity indicative of exploitation attempts. Additionally, restrict direct access to the popup controller endpoints via network segmentation or access control lists where feasible. Maintain up-to-date backups and have an incident response plan ready to address potential compromises.

Description

A SQL Injection vulnerability in the Advanced Popup Creator (advancedpopupcreator) module for PrestaShop 1.1.26 through 1.2.6 (Fixed in version 1.2.7) allows remote unauthenticated attackers to execute arbitrary SQL queries via the fromController parameter in the popup controller. The parameter is passed unsanitized to SQL queries in classes/AdvancedPopup.php (getPopups() and updateVisits() functions).

References

Community reviews

Loading reviews…