Skip to main content
VulnerabilityPublished Updated

CVE-2025-69720: GNU ncurses · Stack-based Buffer Overflow

Affects GNU ncursesSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.3 High : upgrade to 6.5-20251213 soon.

Data as of 31 Oct 2026, 08:20 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.5-20251213
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade GNU ncurses to 6.5-20251213.

Affected software

ProductAffectedFixed in
GNUncursesAffected
  • <6.5-20251213
Fixed in
  • 6.5-20251213

AI-suggested

If you cannot patch yet, avoid running the infocmp tool with untrusted input.

Description

The infocmp command-line tool in ncurses before 6.5-20251213 has a stack-based buffer overflow in analyze_string in progs/infocmp.c.

References

Community reviews

Loading reviews…