CVE-2025-70128: PluXml · Cross-site Scripting
Affects PluXmlSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 6.1 Medium : upgrade to 5.8.23 when convenient.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.8.23
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade pluxml/PluXml to 5.8.23.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubpluxml/PluXmlpkg:github/pluxml/PluXmlOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
In the absence of official patches, administrators should implement strict input validation and sanitization on the 'link' field in comments, employing server-side filtering to remove or encode script tags and other potentially dangerous HTML elements. Restrict administrative panel access using multi-factor authentication (MFA) and IP whitelisting to reduce exposure. Regularly review and sanitize existing comments in the database to remove any malicious payloads. Employ Content Security Policy (CSP) headers to limit the execution of inline scripts within the admin interface. Monitor administrative user activities and logs for suspicious behavior indicative of exploitation attempts. Educate privileged users about the risks of executing untrusted content and the importance of cautious comment management. Finally, segregate administrative interfaces from public-facing systems to minimize attack vectors.
Description
A Stored Cross-Site Scripting (XSS) vulnerability exists in the PluXml article comments feature for PluXml versions 5.8.22 and earlier. The application fails to properly sanitize or validate user-supplied input in the "link" field of a comment. An attacker can inject arbitrary JavaScript code using a <script> element. The injected payload is stored in the database and subsequently rendered in the Administration panel's "Comments" section when administrators review submitted comments. Importantly, the malicious script is not reflected in the public-facing comments interface, but only within the backend administration view. Alternatively, users of Administrator, Moderator, Manager roles can also directly input crafted payloads into existing comments. This makes the vulnerability a persistent XSS issue targeting administrative users. This affects /core/admin/comments.php, while CVE-2022-24585 affects /core/admin/comment.php, a uniquely distinct vulnerability.