Skip to main content
VulnerabilityPublished Updated

CVE-2025-70364: kiamo · Code Injection

Affects kiamoSource CVE Database V5

0

Not known to be exploited · CVSS 8.8 High : upgrade to 8.4 soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade kiamo/kiamo to 8.4.

Affected software

ProductAffectedFixed in
GitHubkiamo/kiamopkg:github/kiamo/kiamoOther threatsAffected
  • <8.4
Fixed in
  • 8.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The vendor has added restrictions on some PHP functions starting with version 8.4, which reduces the risk. Users should upgrade to Kiamo 8.4 or later to benefit from these mitigations. Since this is an intended administrative feature, no additional vendor-provided patches or fixes are currently available. Organizations should ensure strict control and monitoring of administrative access to limit exposure.

Description

An issue was discovered in Kiamo before 8.4 allowing authenticated administrative attackers to execute arbitrary PHP code on the server. NOTE: the Supplier's position is that this is "a historical and intended administrative feature of the product, accessible only to already authenticated users explicitly granted administrator privileges." However, restrictions on some PHP functions were added in 8.4.

References

Community reviews

Loading reviews…