CVE-2025-7056: Wikimedia Foundation Mediawiki – UrlShortener Extension · XSS or 'Cross-site Scripting'
Affects Wikimedia Foundation Mediawiki – UrlShortener ExtensionSource CVE Database V5
Not known to be exploited · CVSS 6.3 Medium : upgrade to 1.44.0 or 1.43.0 when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.44.0, 1.43.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 7 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade wikimedia/mediawiki/extensions/UrlShortener to 1.44.0 or 1.43.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubwikimedia/mediawiki/extensions/UrlShortenerpkg:github/wikimedia/mediawiki/extensions/UrlShortenerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should prioritize upgrading the Mediawiki UrlShortener extension to versions 1.42.7 or 1.43.2 as soon as these patches become available. If you cannot patch yet, organizations should implement strict input validation and output encoding on any user-generated content related to URL shortening features. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts and reduce the impact of potential XSS attacks. Regularly audit and monitor Mediawiki installations for suspicious activity or unexpected content injections. Disable or restrict the UrlShortener extension if it is not essential to reduce the attack surface. Educate users about the risks of clicking on shortened URLs from untrusted sources and encourage cautious behavior. Additionally, implement web application firewalls (WAFs) with rules tailored to detect and block XSS payloads targeting Mediawiki extensions. Finally, maintain up-to-date backups and incident response plans to quickly recover from any compromise resulting from exploitation of this vulnerability.
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation Mediawiki - UrlShortener Extension allows Stored XSS.This issue affects Mediawiki - UrlShortener Extension: from 1.42.X before 1.42.7, from 1.43.X before 1.43.2.