Skip to main content
VulnerabilityPublished Updated

CVE-2025-7062: Lumi Education UG h5p-nodejs-library · Cross-site Scripting

Affects Lumi Education UG h5p-nodejs-librarySource CVE Database V5

0

Not known to be exploited · CVSS 5.2 Medium : upgrade to 10.0.4 when convenient.

Data as of 26 Oct 2026, 08:30 UTC

CVSS 4.0 base score
5.2Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Limited control over the software or limited information exposure

CISA SSVC assessment, 2026-09-09.

Patch
Available – fixed in 10.0.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:N/VI:N/VA:N/SC:H/SI:H/SA:L/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Lumi Education UG h5p-nodejs-library to 10.0.4.

Affected software

ProductAffectedFixed in
Lumi Education UGh5p-nodejs-libraryAffected
  • <10.0.4
Fixed in
  • 10.0.4
GitHubh5p-nodejs-librarypkg:github/h5p-nodejs-libraryOther threatsAffected
  • <10.0.4
Fixed in
  • 10.0.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

A stored cross-site scripting (XSS) vulnerability has been identified in the H5P module `h5p-nodejs-library` by Lumi Education UG in versions up to and including 10.0.4. The library allows users to upload H5P content that contains malicious JavaScript. This code is then executed in the browsers of other users who view the affected H5P content.

References

Community reviews

Loading reviews…