CVE-2025-71100: Linux kernel · Out-of-bounds Read
Affects Linux kernelSource CVE Database V5
Not known to be exploited · CVSS 7.6 High · fixed in dd39edb445f07400e748da967a07d5dca5c5f96e : patch Linux kernel soon.
Data as of 26 Oct 2026, 13:47 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Limited control over the software or limited information exposure
CISA SSVC assessment, 2026-10-16.
- Patch
- Available – fixed in dd39edb445f07400e748da967a07d5dca5c5f96e, 9765d6eb8298b07d499cdf9ef7c237d3540102d6, 90a15ff324645aa806d81fa349497cd964861b66
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Linux kernel to dd39edb445f07400e748da967a07d5dca5c5f96e, 9765d6eb8298b07d499cdf9ef7c237d3540102d6 or 90a15ff324645aa806d81fa349497cd964861b66.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| LinuxLinux | Affected
| Fixed in
|
| LinuxLinux | Affected
| Fixed in
|
| LinuxLinux | Affected
| Fixed in
|
| LinuxLinux | Affected
| Fixed in– |
AI-suggested
A fix is available and has been applied in the Linux kernel versions identified by the commits dd39edb445f07400e748da967a07d5dca5c5f96e, 9765d6eb8298b07d499cdf9ef7c237d3540102d6, and 90a15ff324645aa806d81fa349497cd964861b66. Users should update to the patched Linux kernel version 6.9 or later containing these fixes to remediate the vulnerability.
Description
CVE-2025-71100 is a high-severity vulnerability in the Linux kernel's rtlwifi driver for Realtek 8192cu wireless devices. The flaw involves an out-of-range array index when retrieving the TID (Traffic Identifier) from ieee80211_get_tid(), which can lead to undefined behavior and potential memory corruption. This issue has been fixed by adding a boundary check to ensure the TID is less than MAX_TID_COUNT, preventing out-of-bounds access.