Skip to main content
VulnerabilityPublished Updated

CVE-2025-71112: Linux kernel · net: hns3: add VLAN id validation before using

Affects Linux kernelSource GCVE Database

0
Authoritative record:CVE-2025-71112· High 8.8

Not known to be exploited · CVSS 8.8 High · fixed in 5.15.0-1103.110~20.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.15.0-1103.110~20.04.1, 5.15.0-1110.119~20.04.1, 5.15.0-1103.112~20.04.1 +70
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-22.22?arch=source&distro=questingOther threatsAffected
  • <6.17.0-22.22
Fixed in
  • 6.17.0-22.22
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1012.12?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1012.12
Fixed in
  • 6.17.0-1012.12
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1013.13?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1013.13
Fixed in
  • 6.17.0-1013.13
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1012.12?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1012.12
Fixed in
  • 6.17.0-1012.12
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle@6.17.0-1011.11?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1011.11
Fixed in
  • 6.17.0-1011.11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A vendor patch is available and should be applied to affected Linux kernel versions to address this vulnerability. The Ubuntu security advisory USN-8096-1 provides updated kernel packages that fix this issue. Systems running affected versions should be updated promptly. No additional mitigations are specified by the vendor.

Description

A vulnerability in the Linux kernel's hns3 network driver allows out-of-bounds memory access due to lack of VLAN ID validation when receiving VLAN configuration from a virtual function (VF). This can lead to memory corruption. The issue has been fixed by adding proper VLAN ID validation. Multiple Linux kernel versions prior to specific 5.15.x updates are affected. A patch is available from the vendor.

References

Community reviews

Loading reviews…