Skip to main content
VulnerabilityPublished Updated

CVE-2025-71130: Linux kernel · drm/i915/gem: Zero-initialize the eb.vma array in i915_gem_do_execbuffer

Affects Linux kernelSource GCVE Database

0
Authoritative record:CVE-2025-71130· High 7.8

Not known to be exploited · CVSS 7.8 High · fixed in 6.8.0-1052.55~22.04.1 : patch Linux kernel soon.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.8.0-1052.55~22.04.1, 6.8.0-1059.65~22.04.1, 6.8.0-1054.57~22.04.1 +40
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux@6.17.0-22.22?arch=source&distro=questingOther threatsAffected
  • <6.17.0-22.22
Fixed in
  • 6.17.0-22.22
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws@6.17.0-1012.12?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1012.12
Fixed in
  • 6.17.0-1012.12
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure@6.17.0-1013.13?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1013.13
Fixed in
  • 6.17.0-1013.13
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde@6.17.0-1017.17?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp@6.17.0-1012.12?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1012.12
Fixed in
  • 6.17.0-1012.12
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle@6.17.0-1011.11?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1011.11
Fixed in
  • 6.17.0-1011.11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been incorporated into updated linux-hwe-edge kernel versions. Users should apply the official kernel updates and reboot their systems to ensure the fix is active. The vendor advisory from Ubuntu confirms the availability of the fix and recommends standard system update procedures followed by a reboot. No additional mitigations are required beyond applying the patch.

Description

A vulnerability in the Linux kernel's drm/i915/gem subsystem was fixed by zero-initializing the eb.vma array in the i915_gem_do_execbuffer function. The flaw involved improper initialization of pointers in the eb.vma array, which could lead to a NULL pointer dereference during cleanup after a failure in buffer processing. This issue has been addressed by initializing the array elements to NULL at setup, preventing the NULL dereference bug. The vulnerability affects specific versions of the linux-hwe-edge kernel and has a CVSS score of 7.8. A patch is available, and users should update and reboot to apply the fix.

References

Community reviews

Loading reviews…