CVE-2025-71136: Linux kernel · media: adv7842: Avoid possible out-of-bounds array accesses in adv7842_cp_log_status()
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.1 High · fixed in 5.15.0-1103.110~20.04.1 : patch Linux kernel soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.15.0-1103.110~20.04.1, 5.15.0-1110.119~20.04.1, 5.15.0-1103.112~20.04.1 +74
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 14 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linuxpkg:deb/ubuntu/linux?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied promptly. Ubuntu has released updates fixing this vulnerability in Linux kernel versions 5.15.0-1103.110~20.04.1, 5.15.0-1110.119~20.04.1, 5.15.0-1103.112~20.04.1, 5.15.0-173.183~20.04.1, and 5.15.0-1097.100~20.04.1. Users should update to these fixed versions or later. No additional mitigations are specified or required beyond applying the official fixes.
Description
A vulnerability in the Linux kernel's media subsystem (adv7842 driver) could lead to out-of-bounds array accesses due to unchecked negative return values from cp_read() and hdmi_read() functions. This flaw has been fixed by adding proper return value checks. The vulnerability affects certain Linux kernel versions prior to specific 5.15.x releases. The issue has a CVSS score of 7.1, indicating a medium severity level with high confidentiality impact and high availability impact. A patch is available as part of the Linux kernel updates distributed by Ubuntu and other vendors.
References
- ubuntu.com/security/CVE-2025-71136 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-71136 (opens in a new tab)
- git.kernel.org/stable/c/60dde0960e3ead8a9569f6c494d90d0232ac0983 (opens in a new tab)
- git.kernel.org/stable/c/8163419e3e05d71dcfa8fb49c8fdf8d76908fe51 (opens in a new tab)
- git.kernel.org/stable/c/a73881ae085db5702d8b13e2fc9f78d51c723d3f (opens in a new tab)
- git.kernel.org/stable/c/b693d48a6ed0cd09171103ad418e4a693203d6e4 (opens in a new tab)
- git.kernel.org/stable/c/d6a22a4a96e4dfe6897cb3532d2b3016d87706f0 (opens in a new tab)
- ubuntu.com/security/notices/USN-8096-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8096-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8096-3 (opens in a new tab)
- ubuntu.com/security/notices/USN-8096-4 (opens in a new tab)
- ubuntu.com/security/notices/USN-8116-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8096-5 (opens in a new tab)
- ubuntu.com/security/notices/USN-8141-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8163-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8163-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8177-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8179-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8177-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8183-1 (opens in a new tab)