CVE-2025-71156: Linux kernel · gve: defer interrupt enabling until NAPI registration
Affects Linux kernelSource GCVE Database
Not known to be exploited · CVSS 7.8 High · fixed in 6.17.0-1012.12~24.04.1 : patch Linux kernel soon.
Data as of 26 Oct 2026, 12:55 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.17.0-1012.12~24.04.1, 6.17.0-1013.13~24.04.1, 6.17.0-22.22~24.04.1 +11
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 23 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
- ubuntu.com/security/notices/USN-8177-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8177-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8183-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8183-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8245-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8257-1 (opens in a new tab)
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10linuxpkg:deb/ubuntu/linux?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
In the Linux kernel, the following vulnerability has been resolved: gve: defer interrupt enabling until NAPI registration Currently, interrupts are automatically enabled immediately upon request. This allows interrupt to fire before the associated NAPI context is fully initialized and cause failures like below: [ 0.946369] Call Trace: [ 0.946369] <IRQ> [ 0.946369] __napi_poll+0x2a/0x1e0 [ 0.946369] net_rx_action+0x2f9/0x3f0 [ 0.946369] handle_softirqs+0xd6/0x2c0 [ 0.946369] ? handle_edge_irq+0xc1/0x1b0 [ 0.946369] __irq_exit_rcu+0xc3/0xe0 [ 0.946369] common_interrupt+0x81/0xa0 [ 0.946369] </IRQ> [ 0.946369] <TASK> [ 0.946369] asm_common_interrupt+0x22/0x40 [ 0.946369] RIP: 0010:pv_native_safe_halt+0xb/0x10 Use the `IRQF_NO_AUTOEN` flag when requesting interrupts to prevent auto enablement and explicitly enable the interrupt in NAPI initialization path (and disable it during NAPI teardown). This ensures that interrupt lifecycle is strictly coupled with readiness of NAPI context.
References
- ubuntu.com/security/CVE-2025-71156 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-71156 (opens in a new tab)
- git.kernel.org/linus/3d970eda003441f66551a91fda16478ac0711617 (opens in a new tab)
- git.kernel.org/stable/c/3d970eda003441f66551a91fda16478ac0711617 (opens in a new tab)
- git.kernel.org/stable/c/48f9277680925e1a8623d6b2c50aadb7af824ace (opens in a new tab)
- git.kernel.org/stable/c/f5b7f49bd2377916ad57cbd1210c61196daff013 (opens in a new tab)
- ubuntu.com/security/notices/USN-8177-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8177-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8183-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8183-2 (opens in a new tab)
- ubuntu.com/security/notices/USN-8245-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8257-1 (opens in a new tab)