CVE-2025-71379: vllm · ReDoS
Affects vllmSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 0.9.0 when convenient.
Data as of 8 Nov 2026, 14:20 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 5.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 4.3 |
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Limited control over the software or limited information exposure
CISA SSVC assessment, 2026-06-22.
- Patch
- Available – fixed in 0.9.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 8 Nov 2026.
What to do
Upgrade vllm to 0.9.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| vllmvllm | Affected
| Fixed in
|
PyPIvllmpkg:pypi/vllmOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade vLLM to version 0.9.0 or later, where these ReDoS vulnerabilities have been fixed. No additional mitigation steps are indicated.
Description
vLLM versions from 0.6.3 up to but not including 0.9.0 contain multiple regular expression denial of service (ReDoS) vulnerabilities. These vulnerabilities arise from inefficient regex patterns in several components, including vllm/lora/utils.py, the phi4mini tool parser, and the OpenAI-compatible serving chat endpoint. Crafted input exploiting nested or repeated structures can cause excessive CPU usage and degrade performance, leading to denial of service. The issue is fixed in version 0.9.0.