Skip to main content
VulnerabilityPublished Updated

CVE-2025-9232: OpenSSL · Out-of-bounds Read

Affects OpenSSLSource GCVE Database

0
Compare

Not known to be exploited · CVSS 5.9 Medium · fixed in 3.5.0 : update OpenSSL when convenient.

Data as of 6 Nov 2026, 23:24 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.15.9
EPSS
2.0% chance of exploitation in 30 days – higher than 80% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.5.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
OpenSSL OpenSSLAffected
  • 3.0.16 – 3.5.0
6 affected builds
Fixed in–

AI-suggested

A fix is available in OpenSSL versions released after 3.5.0 (not explicitly listed but implied by the presence of affected versions up to 3.5.0). Users should upgrade to a version later than 3.5.0 to remediate this issue. If upgrading is not immediately possible, avoid setting the 'no_proxy' environment variable or ensure that attacker-controlled URLs are not passed to the OpenSSL HTTP client API functions. The FIPS modules are not affected and require no action.

Description

CVE-2025-9232 is an out-of-bounds read vulnerability in the OpenSSL HTTP client API functions triggered when the 'no_proxy' environment variable is set and the HTTP URL host is an IPv6 address. This flaw can cause application crashes leading to denial of service. The vulnerability affects specific OpenSSL patch releases starting from 3.0.16 through 3.5.0. The FIPS modules are not affected. The issue requires an attacker-controlled URL and the presence of the 'no_proxy' environment variable, resulting in a low likelihood of exploitation and assessed as medium severity.

References

Community reviews

Loading reviews…