Skip to main content
VulnerabilityPublished Updated

CVE-2026-0256: Palo Alto Networks PAN-OS · Cross-site Scripting

Affects Palo Alto Networks PAN-OSSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.4 Medium · fixed in 12.1.7 : update Palo Alto Networks PAN-OS when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
4.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 12.1.7, 11.2.12, 11.1.15 +1
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N/E:U/AU:N/R:U/V:D/RE:M/U:Amber

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Palo Alto Networks PAN-OS to 12.1.7, 11.2.12, 11.1.15 or 10.2.18-h6.

Affected software

ProductAffectedFixed in
Palo Alto NetworksPAN-OSAffected
  • >=12.1.0 <12.1.7
Fixed in
  • 12.1.7
Palo Alto NetworksPAN-OSAffected
  • >=11.2.0 <11.2.12
Fixed in
  • 11.2.12
Palo Alto NetworksPAN-OSAffected
  • >=11.1.0 <11.1.15
Fixed in
  • 11.1.15
Palo Alto NetworksPAN-OSAffected
  • >=10.2.0 <10.2.18-h6
Fixed in
  • 10.2.18-h6

AI-suggested

Restrict administrative access to trusted personnel and networks to reduce risk until a patch or official mitigation is available.

Description

A stored cross-site scripting (XSS) vulnerability in Palo Alto Networks PAN-OS® software enables a malicious authenticated administrator to store a JavaScript payload using the web interface. This issue is applicable to PAN-OS software on PA-Series and VM-Series firewalls and on Panorama (virtual and M-Series). Cloud NGFW and Prisma® Access are not impacted by this vulnerability.

References

Community reviews

Loading reviews…