CVE-2026-100300: Apache ZooKeeper · Improper Handling of Exceptional Conditions
Affects Apache ZooKeeperSource CVE Database V5
Not known to be exploited · CVSS 8.7 High · fixed in 3.8.8 : patch Apache ZooKeeper soon.
Data as of 4 Nov 2026, 11:43 UTC
Thin evidence
One scorer or none| CNA (apache) | CVSS 4.0 | 8.7 |
|---|
- Patch
- Available – fixed in 3.8.8
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache ZooKeeperorg.apache.zookeeper:zookeeper | Affected
| Fixed in– |
Mavenorg.apache.zookeeper/zookeeperpkg:maven/org.apache.zookeeper/zookeeperOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache ZooKeeper to version 3.8.8 or 3.9.7 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated. Applying the official fix is the recommended remediation.
Description
Improper handling of exceptional conditions in the quota subsystem of Apache ZooKeeper allows an attacker able to write under the /zookeeper/quota subtree — unauthenticated on default deployments, where that subtree is world-writable — to crash the server's critical request-processing thread and render the on-disk data directory permanently unbootable. This issue affects Apache ZooKeeper up to and including 3.9.6. Users are recommended to upgrade to version 3.8.8 or 3.9.7, which fixes the issue.