Skip to main content
VulnerabilityPublished

CVE-2026-10056: Network Optix Nx Witness VMS · Permissive Cross-Origin Resource Sharing Policy

Affects Network Optix Nx Witness VMSSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 6.1.2 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.1.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 24 Oct 2026.

What to do

Upgrade Network Optix Nx Witness VMS to 6.1.2.

Affected software

ProductAffectedFixed in
Network OptixNx Witness VMSAffected
  • <6.1.2
Fixed in
  • 6.1.2

AI-suggested

A fix is available by updating Nx Witness VMS to version 6.1.2 or later, which corrects the CORS policy by setting Access-Control-Allow-Credentials to false in the default Standard security configuration. For existing installations that cannot immediately update, a workaround is to set Access-Control-Allow-Credentials to false manually via the REST API PATCH /rest/v2/system/settings with the body {"supportedOrigins": "null"}. Alternatively, selecting High security mode during initial setup avoids this vulnerability. No other mitigation steps are indicated by the vendor.

Description

CORS misconfiguration in the REST API of Network Optix Nx Witness VMS before version 6.1.2, when running in the default Standard security mode, on Linux and Windows allows an unauthenticated remote attacker to steal the session token of an authenticated user and perform Administrator Account Takeover via a malicious cross-origin web page visited by the victim. The High security mode is not affected.Workaround: For existing installations running in Standard security mode, set Access-Control-Allow-Credentials to false via the REST API: PATCH /rest/v2/system/settings with body {"supportedOrigins": "null"}. Alternatively, select High security level during initial setup. Solution: Update to Nx Witness VMS version 6.1.2 or later, in which Access-Control-Allow-Credentials is set to false in the default Standard security configuration.

References

Community reviews

Loading reviews…