Skip to main content
VulnerabilityPublished

CVE-2026-101259: Apache Camel · Generation of Error Message Containing Sensitive Information

Affects Apache CamelSource CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium : upgrade to 4.22.2 or 4.18.5 when convenient.

Data as of 26 Oct 2026, 17:30 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.22.2, 4.18.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Apache to 4.22.2 or 4.18.5.

Affected software

ProductAffectedFixed in
Apache Camelorg.apache.camel:camel-coapAffected
  • >=4.19.0 <4.22.2
Fixed in
  • 4.22.2
Apache Camelorg.apache.camel:camel-coapAffected
  • >=4.0.0 <4.18.5
Fixed in
  • 4.18.5
MavenApache Software Foundation/org.apache.camel:camel-coappkg:maven/Apache Software Foundation/org.apache.camel:camel-coapOther threatsAffected
  • >=4.0.0 <4.18.5
  • >=4.19.0 <4.22.2
Fixed in
  • 4.18.5
  • 4.22.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Camel to versions 4.18.5, 4.22.2, or later 4.23.0, where the issue is fixed and the muteException option is enabled by default to suppress sensitive error payloads. For deployments unable to upgrade immediately, ensure that the response can always be built once the route has completed by converting the body to byte[] or String as the last step of each route consuming from a CoAP endpoint. Additionally, restrict CamelCoapMaxAge and CamelCoapETag headers to values of their own types and add an onException handler that marks failures as handled and sets the response body explicitly. This prevents conversion failures outside the route and suppresses sensitive error details.

Description

CVE-2026-101259 is a vulnerability in the Apache Camel CoAP component affecting versions from 4.0.0 before 4.18.5 and from 4.19.0 before 4.22.2. It allows generation of error messages containing sensitive internal information such as class names, file paths, host names, and connection details. This occurs when the CoAP consumer fails to build its response after route completion and returns detailed exception messages in a 5.00 Internal Server Error response. The issue is fixed in Apache Camel versions 4.18.5, 4.22.2, and later 4.23.0. Users are advised to upgrade to these fixed versions to prevent sensitive information disclosure.

References

Community reviews

Loading reviews…