Skip to main content
VulnerabilityPublished Updated

CVE-2026-10156: Open5GS · Resource Consumption

Affects Open5GSSource CVE Database V5

0
Compare

Public exploit available · CVSS 5.3 Medium.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Open5GSAffected
  • 2.7.0 – 2.7.7
8 affected builds
Fixed in–
GitHubopen5gs/open5gspkg:github/open5gs/open5gsOther threatsAffected
  • 2.7.0 – 2.7.7
8 affected builds
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:open5gs:open5gs:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The issue is flagged as already fixed. Although no direct patch link or vendor advisory is provided, it is recommended to apply the official patch or update to a version later than 2.7.7 where the vulnerability is resolved. Patch status is not explicitly confirmed in the data, so users should verify with the Open5GS project or vendor advisory for the latest remediation guidance before deployment.

Description

CVE-2026-10156 is a medium severity vulnerability in Open5GS versions up to 2.7.7 affecting the handle_amf_info function in the nf-instances Endpoint component. It allows remote attackers to manipulate the nf_info_pool argument, causing resource consumption. The vulnerability has been publicly disclosed and is flagged as already fixed. No explicit patch link or vendor advisory is provided in the data, but applying the available fix is advised to resolve the issue.

References

Community reviews

Loading reviews…