CVE-2026-10214: zhayujie chatgpt-on-wechat · OS Command Injection
Affects zhayujie chatgpt-on-wechatSource CVE Database V5
Public exploit available · CVSS 6.9 Medium.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 1.4% chance of exploitation in 30 days – higher than 73% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 1 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| zhayujiechatgpt-on-wechat | Affected
| Fixed in– |
PyPIchatgpt-on-wechatpkg:pypi/chatgpt-on-wechatOther threats | Affected
| Fixed in– |
CPE configurations (1)
cpe:2.3:a:zhayujie:chatgpt-on-wechat:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade the zhayujie chatgpt-on-wechat application to version 2.0.9 or later, which contains the official fix for this OS command injection vulnerability. No other mitigations are specified. Patch status is confirmed by the vendor's version update and commit reference.
Description
A weakness has been identified in zhayujie chatgpt-on-wechat up to 2.0.8. This issue affects the function _get_safety_warning of the file agent/tools/bash/bash.py of the component Bash Tool. Executing a manipulation can lead to os command injection. The attack can be launched remotely. The exploit has been made available to the public and could be used for attacks. Upgrading to version 2.0.9 is capable of addressing this issue. This patch is called 16d9b449c9aa53ccee44144a762a2737d7ba4fc4. It is recommended to upgrade the affected component.
References
- vuldb.com/vuln/367493 (opens in a new tab)
- vuldb.com/vuln/367493/cti (opens in a new tab)
- vuldb.com/cve/CVE-2026-10214 (opens in a new tab)
- vuldb.com/submit/821929 (opens in a new tab)
- github.com/zhayujie/CowAgent/issues/2803 (opens in a new tab)
- github.com/zhayujie/CowAgent/commit/16d9b449c9aa53ccee44144a762a2737d7ba4fc4 (opens in a new tab)
- github.com/zhayujie/CowAgent/releases/tag/2.0.9 (opens in a new tab)