Skip to main content
VulnerabilityPublished Updated

CVE-2026-102639: MobilityDB · Signed to Unsigned Conversion Error

Affects MobilityDBSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High : upgrade to 1.3.1 or 1.2.2 soon.

Data as of 8 Nov 2026, 14:19 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.07.1
CNA (VulnCheck)CVSS 3.16.5
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Limited control over the software or limited information exposure

CISA SSVC assessment, 2026-10-02.

Patch
Available – fixed in 1.3.1, 1.2.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 8 Nov 2026.

What to do

Upgrade MobilityDB to 1.3.1 or 1.2.2.

Affected software

ProductAffectedFixed in
MobilityDBMobilityDBAffected
  • >=1.1.0 <=1.1.2
  • >=1.2.0 <1.2.2
  • >=1.3.0 <1.3.1
Fixed in
  • 1.3.1
  • 1.2.2
GitHubMobilityDBpkg:github/MobilityDBOther threatsAffected
  • >=1.1.0 <=1.1.2
  • >=1.2.0 <1.2.2
  • >=1.3.0 <1.3.1
Fixed in
  • 1.2.2
  • 1.3.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in MobilityDB versions 1.3.1 and 1.2.2. Users should upgrade to these versions or later to remediate this vulnerability. No other mitigations are indicated or required.

Description

MobilityDB versions up to 1.3.0 contain a vulnerability in the WKB deserialization logic where a signed to unsigned conversion error allows unprivileged users to cause a denial-of-service by crashing the PostgreSQL backend. This occurs due to a negative length field in a crafted WKB payload that bypasses bounds checks and leads to out-of-bounds memory reads during memcpy operations.

References

Community reviews

Loading reviews…