Skip to main content
VulnerabilityPublished

CVE-2026-102894: gpustack · Authentication Bypass by Capture-replay

Affects gpustackSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical : upgrade to 2.2.2 as a priority.

Data as of 4 Nov 2026, 23:44 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.19.1
Patch
Available – fixed in 2.2.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade gpustack and gpustack/gpustack to 2.2.2.

Affected software

ProductAffectedFixed in
gpustackgpustackAffected
  • >=0.7.1 <2.2.2
Fixed in
  • 2.2.2
GitHubgpustack/gpustackpkg:github/gpustack/gpustackOther threatsAffected
  • >=0.7.1 <2.2.2
Fixed in
  • 2.2.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade GPUStack to version 2.2.2 or later, where the SAML authentication process properly verifies signatures and security conditions. No other mitigations are indicated or required as the fix addresses the root cause.

Description

CVE-2026-102894 is a critical authentication bypass vulnerability in GPUStack versions from 0.7.1 up to but not including 2.2.2. The vulnerability occurs because the /auth/saml/callback endpoint fails to verify SAML response signatures and related security conditions, allowing attackers to impersonate existing users or provision new accounts without proper authentication. This flaw is fixed in version 2.2.2.

References

Community reviews

Loading reviews…