Skip to main content
VulnerabilityPublished

CVE-2026-103995: Python Software Foundation CPython · HTTP Request/Response Smuggling

Affects Python Software Foundation CPythonSource CVE Database V5

0

Not known to be exploited · CVSS 2.0 Low : upgrade to 3.16.0 when convenient.

Data as of 27 Oct 2026, 20:27 UTC

CVSS 4.0 base score
2.0Low
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.16.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:P/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Python Software Foundation CPython to 3.16.0.

Affected software

ProductAffectedFixed in
Python Software FoundationCPythonAffected
  • <3.16.0
Fixed in
  • 3.16.0
GitHubCPythonpkg:github/CPythonOther threatsAffected
  • <3.16.0
Fixed in
  • 3.16.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade CPython to version 3.16.0 or later, where this vulnerability has been fixed. No other mitigation actions are indicated by the vendor advisory.

Description

CVE-2026-103995 is a vulnerability in CPython where the HTTP response body and chunk parsing incorrectly handle non-hexadecimal or negative integers. This flaw can cause misinterpretation of HTTP response contents, potentially leading to HTTP request/response smuggling attacks. The issue affects CPython versions prior to 3.16.0 and has been fixed in version 3.16.0. The vulnerability has a low severity rating and no known exploits in the wild.

References

Community reviews

Loading reviews…