Skip to main content
VulnerabilityPublished

CVE-2026-10514: 1Panel-dev CordysCRM · Cross-site Scripting

Affects 1Panel-dev CordysCRMSource CVE Database V5

0
Compare

Public exploit available · CVSS 4.8 Medium.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
1Panel-devCordysCRMAffected
  • =1.6.0
  • =1.6.1
  • =1.6.2
Fixed in–
GitHub1panel-dev/CordysCRMpkg:github/1panel-dev/CordysCRMOther threatsAffected
  • =1.6.0
  • =1.6.1
  • =1.6.2
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:1panel-dev:cordyscrm:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade affected installations of 1Panel-dev CordysCRM from versions 1.6.0, 1.6.1, or 1.6.2 to version 1.7.0 or later, which includes the patch for this vulnerability (commit c87682afa8df79853299f75489c9d333f7bc5fce). No other mitigations are specified or confirmed by the vendor advisory.

Description

CVE-2026-10514 is a cross-site scripting (XSS) vulnerability affecting 1Panel-dev CordysCRM versions 1.6.0 through 1.6.2. The issue exists in an unspecified function within the file backend/framework/src/main/java/cn/cordys/config/RequestParamTrimConfig.java. Remote attackers can exploit this vulnerability. Upgrading to version 1.7.

References

Community reviews

Loading reviews…