Skip to main content
VulnerabilityPublished Updated

CVE-2026-105192: LMCache · Deserialization of Untrusted Data

Affects LMCacheSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.8 Critical : upgrade to 0.5.6 as a priority.

Data as of 29 Oct 2026, 10:48 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (JFROG)CVSS 3.19.8
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers can reliably automate steps 1–4 of the kill chain
Technical impact
Total control over the software or total information disclosure

CISA SSVC assessment, 2026-10-07.

Patch
Available – fixed in 0.5.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade LMCache and lmcache to 0.5.6.

Affected software

ProductAffectedFixed in
LMCachelmcacheAffected
  • >=0.3.9 <0.5.6
Fixed in
  • 0.5.6
PyPIlmcachepkg:pypi/lmcacheOther threatsAffected
  • >=0.3.9 <0.5.6
Fixed in
  • 0.5.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade LMCache to version 0.5.6 or later, which removes the unsafe pickle.loads call from the message deserialization path. Until upgraded, avoid exposing the LMCache transport port on routable network interfaces by not setting the --host option or restricting access to localhost only. Running LMCache with least privilege rather than root can reduce impact but does not eliminate the vulnerability. There are no vendor advisories indicating alternative mitigations or that no action is required.

Description

LMCache versions from 0.3.9 up to but not including 0.5.6 contain a critical deserialization vulnerability in multiprocess (distributed) mode. This mode opens an unauthenticated ZeroMQ ROUTER socket that accepts msgpack messages. When processing these messages, the server calls pickle.loads on untrusted data before request handling, allowing remote code execution as the LMCache process user. Official containers run this process as root, increasing risk. The vulnerability is fixed in version 0.5.6, which removes the unsafe pickle.loads call.

References

Community reviews

Loading reviews…