Skip to main content
VulnerabilityPublished

CVE-2026-10524: CoCart (WordPress plugin) · External Control of Assumed-Immutable Web Parameter

Affects CoCart (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 4.9.0 soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.9.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade CoCart (WordPress plugin) to 4.9.0.

Affected software

ProductAffectedFixed in
CoCartAffected
  • <4.9.0
Fixed in
  • 4.9.0

AI-suggested

If you cannot patch yet, restrict access to the affected REST API endpoints if possible, and monitor for unusual order activity. Avoid relying on client-supplied price data for order processing.

Description

CVE-2026-10524 is a vulnerability in the CoCart WordPress plugin before version 4.9.0. It allows unauthenticated users to manipulate product prices by supplying arbitrary price values through a public REST API endpoint. This flaw enables attackers to complete WooCommerce orders at manipulated totals without validation against actual product prices.

References

Community reviews

Loading reviews…