Skip to main content
VulnerabilityPublished

CVE-2026-10530: Pie Register (WordPress plugin) · Inadequate Encryption Strength

Affects Pie Register (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 3.8.4.10 when convenient.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.8.4.10
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade Pie Register (WordPress plugin) to 3.8.4.10.

Affected software

ProductAffectedFixed in
Pie RegisterAffected
  • <3.8.4.10
Fixed in
  • 3.8.4.10

AI-suggested

Users should monitor the vendor's announcements for an official fix or update to address the token generation randomness issue.

Description

The Pie Register WordPress plugin before 3.8.4.10 does not use sufficiently random values when generating its account verification tokens, allowing unauthenticated attackers to predict a valid token and activate an account without access to the associated email inbox.

References

Community reviews

Loading reviews…