Skip to main content
VulnerabilityPublished Updated

CVE-2026-105945: Apache Pulsar · Path Traversal

Affects Apache PulsarSource CVE Database V5

0

Not known to be exploited · CVSS 7.7 High : upgrade to 4.2.5 or 4.0.14 soon.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 4.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.2.5, 4.0.14
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:L/SA:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Apache Pulsar and org.apache.pulsar/pulsar to 4.2.5 or 4.0.14.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache PulsarAffected
  • >=4.1.0 <4.2.5
Fixed in
  • 4.2.5
Apache Software FoundationApache PulsarAffected
  • >=2.10.0 <4.0.14
Fixed in
  • 4.0.14
Mavenorg.apache.pulsar/pulsarpkg:maven/org.apache.pulsar/pulsarOther threatsAffected
  • >=2.10.0 <4.0.14
  • >=4.1.0 <4.2.5
Fixed in
  • 4.0.14
  • 4.2.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available. Users should upgrade Apache Pulsar to at least version 4.0.14 if using the 4.0.x line, or to at least version 4.2.5 if using the 4.1.x or 4.2.x lines. Users on versions prior to these should upgrade to these patched versions or newer. Additionally, package management is disabled by default; disabling it if not needed reduces exposure. The default storage provider (Apache BookKeeper) is not affected. No other mitigations are specified.

Description

The Pulsar Packages Management Service can be configured to store packages on the local filesystem of the broker by using the filesystem storage provider. Package names consist of a type, tenant, namespace, name and version. Authorization of package operations is based only on the tenant and namespace, while the storage location of a package is derived from all of these components. The version component of a package name was not validated, so it could contain URL-encoded path separators and parent directory references. The filesystem storage provider resolved such a version to a location belonging to a package in a different tenant or namespace. Because that location is inside the configured storage directory, the containment check that the filesystem storage provider performs in recent releases did not prevent the access. An authenticated user who has the packages permission on any namespace could use this to download, overwrite or delete packages stored in other tenants or namespaces for which the user has no permission. Packages overwritten or deleted in this way may be used by Pulsar Functions, Sources or Sinks, so the issue can affect the integrity and availability of these components. If authentication is disabled, the operations are available to any client that can reach the broker's admin REST API. This issue only affects deployments in which package management is enabled with the broker setting enablePackagesManagement and the filesystem storage provider (FileSystemPackagesStorageProvider) is configured with the setting packagesManagementStorageProvider. Package management is disabled by default, and the default storage provider, which stores packages in Apache BookKeeper, is not affected. This issue affects Apache Pulsar versions from 2.10.0 before 4.0.14 and from 4.1.0 before 4.2.5. - 4.0.x version users should upgrade to at least 4.0.14. - 4.1.x and 4.2.x version users should upgrade to at least 4.2.5. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions. The currently supported Apache Pulsar release lines are 4.0.x and 5.0.x. The supported versions schedule is available at https://pulsar.apache.org/contribute/release-policy/.

References

Community reviews

Loading reviews…