Skip to main content
VulnerabilityPublished

CVE-2026-105987: KGS Software tia Viewer · Cross-site Scripting

Affects KGS Software tia ViewerSource CVE Database V5

0

Not known to be exploited · CVSS 5.1 Medium : upgrade to 1.2.8 when convenient.

Data as of 27 Oct 2026, 14:57 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.2.8
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade KGS Software tia Viewer to 1.2.8.

Affected software

ProductAffectedFixed in
KGS Softwaretia ViewerAffected
  • <1.2.8
Fixed in
  • 1.2.8

AI-suggested

Upgrade to tia Viewer version 1.2.8 or later, where this vulnerability has been fixed.

Description

KGS Software tia Viewer versions prior to 1.2.8 are vulnerable to a stored Cross-site Scripting (XSS) flaw via the annotation API. An authenticated attacker can inject malicious JavaScript into stickynote annotations, which executes when any user views the document, potentially compromising user sessions. The vulnerability has been fixed in version 1.2.8.

References

Community reviews

Loading reviews…