Skip to main content
VulnerabilityPublished

CVE-2026-107347: HashiCorp Nomad · Link Following

Affects HashiCorp NomadSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.4 High : upgrade to 2.1.0 soon.

Data as of 29 Oct 2026, 18:49 UTC

CVSS 3.1 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (HashiCorp)CVSS 3.18.4
Patch
Available – fixed in 2.1.0, 1.11.12
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Nomad and Nomad Enterprise to 2.1.0; Nomad Enterprise to 1.11.12.

Affected software

ProductAffectedFixed in
HashiCorpNomadAffected
  • >=0.3.0 <2.1.0
Fixed in
  • 2.1.0
HashiCorpNomad EnterpriseAffected
  • >=0.3.0 <1.11.12
Fixed in
  • 2.1.0
GitHubNomadpkg:github/NomadOther threatsAffected
  • >=0.3.0 <2.1.0
Fixed in
  • 2.1.0
GitHubNomad Enterprisepkg:github/Nomad EnterpriseOther threatsAffected
  • >=0.3.0 <1.11.12
Fixed in
  • 1.11.12

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in Nomad 2.1.0 and Nomad Enterprise 2.1.0, 1.11.12, and 1.10.18. Users should upgrade to these fixed versions to remediate the issue. No additional mitigation steps are indicated beyond applying the official patches.

Description

HashiCorp Nomad and Nomad Enterprise contain a vulnerability (CVE-2026-107347) involving improper symlink resolution during dispatch payload and executor log writes. This flaw allows a malicious workload to modify files outside its allocation directory. If the Nomad client agent runs with root privileges, exploitation could lead to root code execution on the host. The issue is fixed in Nomad versions 2.1.0, 1.11.12, and 1.10.18.

References

Community reviews

Loading reviews…