Skip to main content
VulnerabilityPublished

CVE-2026-10753: Site Kit by Google (WordPress plugin) · Incorrect Authorization

Affects Site Kit by Google (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 2.7 Low : upgrade to 1.176.0 when convenient.

Data as of 6 Nov 2026, 23:24 UTC

CVSS 3.1 base score
2.7Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.176.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade Site Kit by Google (WordPress plugin) to 1.176.0.

Affected software

ProductAffectedFixed in
Site Kit by GoogleAffected
  • <1.176.0
Fixed in
  • 1.176.0

AI-suggested

If you cannot patch yet, restrict dashboard sharing access to trusted users only and monitor for unauthorized changes to Site Kit plugin settings.

Description

The Site Kit by Google WordPress plugin before 1.176.0 does not properly restrict a REST API write endpoint to administrators, allowing lower-privileged users who have been granted dashboard sharing access (such as Editors) to modify a site-wide Site Kit by Google WordPress plugin before 1.176.0 setting that should only be modifiable by administrators.

References

Community reviews

Loading reviews…