CVE-2026-10757: Esri ArcGIS Server · SQL Injection
Affects Esri ArcGIS ServerSource CVE Database V5
Not known to be exploited · CVSS 9.8 Critical : upgrade to 12.1 as a priority.
Data as of 26 Oct 2026, 19:57 UTC
- Patch
- Available – fixed in 12.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 26 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Esri ArcGIS Server to 12.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| EsriArcGIS Server | Affected
| Fixed in
|
AI-suggested
A patch is available starting with Esri ArcGIS Server version 12.1 and for other supported versions including 12.0, 11.5, 11.3, and 11.1. Users should upgrade to one of these supported versions and apply the patch to remediate the vulnerability. Versions in mature or retired status are not patch eligible; users of these versions should upgrade to a supported release. No additional vendor mitigation guidance is provided.
Description
There is a SQL injection vulnerability in Esri ArcGIS Server versions 12.1 and earlier on Windows and Linux that may allow a remote attacker with privileges to access the service (which could, depending on the service being configured in a non-default access configuration “public”, include an anonymous attacker) to issue database specific functions that should not be allowed. A patch is provided for ArcGIS Server software in General Availability and Extended support status, which includes versions 12.1, 12.0, 11.5, 11.3, and 11.1. Other versions are in mature or retired status, which are not patch eligible. Users working with unlisted versions are advised to upgrade and apply the patch.