Skip to main content
VulnerabilityPublished Updated

CVE-2026-107618: Gitea cross-site request forgery on repository topics

Affects GiteaSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.1 High : upgrade to 28.2.0 soon.

Data as of 29 Oct 2026, 17:07 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.18.1
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Total control over the software or total information disclosure

CISA SSVC assessment, 2026-10-29.

Patch
Available – fixed in 28.2.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade go-gitea/gitea to 28.2.0.

Affected software

ProductAffectedFixed in
Giteagitea.devAffected
  • <=28.1.0
Fixed in–
GitHubgo-gitea/giteapkg:github/go-gitea/giteaOther threatsAffected
  • <28.2.0
Fixed in
  • 28.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, administrators should avoid visiting untrusted websites while logged into Gitea or restrict repository administration privileges to trusted users only.

Description

A cross-site request forgery (CSRF) vulnerability in Gitea versions up to 28.1.0 allows a repository administrator to have the topics of their repository changed by visiting a malicious page. The affected endpoint lacks proper sign-in middleware, enabling unauthorized cross-origin requests. No other repository settings are affected through this route.

References

Community reviews

Loading reviews…