Skip to main content
VulnerabilityPublished

CVE-2026-107846: bitcoinjs-lib · Improper Validation of Integrity Check Value

Affects bitcoinjs-libSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.3 Critical · fixed in 7.0.2 : patch bitcoinjs-lib as a priority.

Data as of 4 Nov 2026, 21:42 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.09.3
Patch
Available – fixed in 7.0.2, 6.1.8, 5.2.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:H/VA:L/SC:N/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade bitcoinjs-lib to 7.0.2, 6.1.8 or 5.2.1; bitcoinjs-lib to 7.0.2 or 6.1.8.

Affected software

ProductAffectedFixed in
bitcoinjsbitcoinjs-libAffected
  • >=7.0.0-rc.0 <7.0.2
Fixed in
  • 7.0.2
bitcoinjsbitcoinjs-libAffected
  • >=6.0.0 <6.1.8
Fixed in
  • 6.1.8
bitcoinjsbitcoinjs-libAffected
  • >=2.3.0 <5.2.1
Fixed in
  • 5.2.1
npmbitcoinjs-libpkg:npm/bitcoinjs-libOther threatsAffected
  • >=6.0.0 <6.1.8
  • >=7.0.0-rc.0 <7.0.2
Fixed in
  • 6.1.8
  • 7.0.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users and developers should upgrade bitcoinjs-lib to version 5.2.1, 6.1.8, or 7.0.2 or later, where this vulnerability is fixed. No other mitigation is required as the issue is resolved in these official releases.

Description

bitcoinjs-lib versions from 2.3.0 up to but not including 5.2.1, 6.0.0 up to 6.1.8, and 7.0.0-rc.0 up to 7.0.2 contain a vulnerability in Merkle root validation. The library's fastMerkleRoot function pads odd Merkle-tree levels by hashing the final node with itself but does not detect adjacent duplicate hashes, allowing a peer to append duplicate transactions without changing the Merkle root or block identifiers. This can cause consumers relying on block-root validation, such as explorers or SPV clients, to process duplicated transactions or reject valid blocks. The issue is fixed in versions 5.2.1, 6.1.8, and 7.0.2.

References

Community reviews

Loading reviews…