CVE-2026-108514: Drupal core · Cross-site Scripting
Affects Drupal coreSource CVE Database V5
Not known to be exploited · fixed in 12.0.0-beta2 : patch Drupal core soon.
Data as of 30 Oct 2026, 04:15 UTC
Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD
Thin evidence
One scorer or none- Patch
- Available – fixed in 12.0.0-beta2, 11.4.10, 11.3.19 +1
Exploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Drupal core to 12.0.0-beta2, 11.4.10, 11.3.19 or 10.6.19.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DrupalDrupal core | Affected
| Fixed in
|
| DrupalDrupal core | Affected
| Fixed in
|
| DrupalDrupal core | Affected
| Fixed in
|
| DrupalDrupal core | Affected
| Fixed in
|
AI-suggested
Apply the official fixes by upgrading Drupal core to versions 10.6.19, 11.3.19, 11.4.10, or 12.0.0-beta2 or later. These versions contain patches that address the XSS vulnerability. No additional mitigation is indicated by the vendor advisory.
Description
A Cross-Site Scripting (XSS) vulnerability exists in Drupal core versions from 10.3.0 up to but not including 10.6.19, 11.0.0 up to but not including 11.3.19, 11.4.0 up to but not including 11.4.10, and 12.0.0-alpha1 up to but not including 12.0.0-beta2. This vulnerability is due to improper neutralization of input during web page generation, allowing injection of malicious scripts.