CVE-2026-109090: x.org libXi · Heap-based Buffer Overflow
Affects x.org libXiSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 1.8.4 soon.
Data as of 27 Oct 2026, 17:24 UTC
- Patch
- Available – fixed in 1.8.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade libXi and x.org/libxi to 1.8.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| x.orglibXi | Affected
| Fixed in
|
X.orgx.org/libxipkg:deb/x.org/libxiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade libXi to version 1.8.4 or later to remediate this vulnerability. No other mitigation is indicated by the vendor advisory.
Description
CVE-2026-109090 is a heap-based buffer overflow vulnerability in the x.org libXi library versions prior to 1.8.4. It occurs when a malicious X server sends an excessively large DEVICE_ENABLE reply, causing libXi to overflow its heap buffer. This flaw was fixed in version 1.8.4.