Skip to main content
VulnerabilityPublished

CVE-2026-109161: Welotec TK100 · Classic Buffer Overflow

Affects Welotec TK100Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 3.5.116 when convenient.

Data as of 3 Nov 2026, 09:28 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (CERTVDE)CVSS 4.06.9
CNA (CERTVDE)CVSS 3.14.9
Patch
Available – fixed in 3.5.116, 1.0.124, 1.0.123
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade TK100 to 3.5.116; TK500-v2 to 1.0.124; TK500-v3 to 1.0.123.

Affected software

ProductAffectedFixed in
WelotecTK100Affected
  • <3.5.116
Fixed in
  • 3.5.116
WelotecTK500-v2Affected
  • <1.0.124
Fixed in
  • 1.0.124
WelotecTK500-v3Affected
  • <1.0.123
Fixed in
  • 1.0.123

AI-suggested

Fixed versions 3.5.116, 1.0.124, and 1.0.123 are available and should be applied to remediate this vulnerability. There is no indication that additional mitigations or workarounds are necessary.

Description

CVE-2026-109161 is a classic buffer overflow vulnerability in the Welotec TK100 device's Digital I/O function. It arises from insufficient bounds checking and can be exploited by a remote attacker with high privileges to cause a denial of service. The issue affects multiple versions prior to 3.5.116, 1.0.124, and 1.0.123. The vulnerability has a medium severity rating with a CVSS score of 6.9. A fix is available in the specified versions.

References

Community reviews

Loading reviews…