Skip to main content
VulnerabilityPublished Updated

CVE-2026-109291: open-webui · Cross-site Scripting

Affects open-webuiSource CVE Database V5

0

Not known to be exploited · CVSS 8.5 High : upgrade to 0.11.4 soon.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Total control over the software or total information disclosure

CISA SSVC assessment, 2026-10-18.

Patch
Available – fixed in 0.11.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade open-webui to 0.11.4.

Affected software

ProductAffectedFixed in
open-webuiopen-webuiAffected
  • >=0.6.33 <0.11.4
Fixed in
  • 0.11.4
PyPIopen-webuipkg:pypi/open-webuiOther threatsAffected
  • >=0.6.33 <0.11.4
Fixed in
  • 0.11.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Open WebUI to version 0.11.4 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated by the vendor advisory.

Description

Open WebUI versions from 0.6.33 up to but not including 0.11.4 contain a cross-site scripting (XSS) vulnerability. Authenticated users can exploit this flaw by storing malicious javascript: URLs in citation embed_url fields. When a victim clicks on a crafted chat citation, the malicious script executes in their session, potentially allowing attackers to steal localStorage tokens and impersonate the victim. This vulnerability is fixed in version 0.11.4.

References

Community reviews

Loading reviews…