Skip to main content
VulnerabilityPublished

CVE-2026-109411: Samba · Improper Handling of Case Sensitivity

Affects SambaSource CVE Database V5

0

Not known to be exploited · CVSS 8.1 High : upgrade to 4.25.1 soon.

Data as of 28 Oct 2026, 20:41 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.25.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Samba to 4.25.1.

Affected software

ProductAffectedFixed in
SambasambaAffected
  • >=4.25.0 <4.25.1
Fixed in
  • 4.25.1

AI-suggested

The vulnerability is mitigated by disabling the experimental vfs_ceph_rgw module on affected Samba shares by removing 'ceph_rgw' from the 'vfs objects' setting in smb.conf and reloading the Samba service. Alternatively, setting 'case sensitive = yes' on affected shares prevents the bypass by treating differently-cased filenames as distinct objects. A fixed Samba version 4.25.1 is available and should be applied to affected deployments. Red Hat standard packages are not affected and do not require action.

Description

CVE-2026-109411 is an access control bypass vulnerability in Samba's experimental vfs_ceph_rgw module. It occurs when an authenticated user accesses files with mismatched case, causing the module to incorrectly treat the operation as creating a new file and skip permission checks. This allows unauthorized reading or overwriting of restricted files on shares configured with this module. The flaw affects Samba versions from 4.25.0 up to but not including 4.25.1. The vulnerability is limited to deployments using the experimental S3-to-SMB gateway feature and is not present in standard Red Hat packages. A fix is available in Samba 4.25.1.

References

Community reviews

Loading reviews…