CVE-2026-109572: open-webui · Missing Authorization
Affects open-webuiSource CVE Database V5
Not known to be exploited · CVSS 7.2 High : upgrade to 0.11.4 soon.
Data as of 26 Oct 2026, 13:47 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Limited control over the software or limited information exposure
CISA SSVC assessment, 2026-10-13.
- Patch
- Available – fixed in 0.11.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 12 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade open-webui to 0.11.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| open-webuiopen-webui | Affected
| Fixed in
|
PyPIopen-webuipkg:pypi/open-webuiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Open WebUI to version 0.11.4 or later, where this privilege escalation vulnerability is fixed. No other mitigation is indicated by the vendor advisory.
Description
Open WebUI versions from 0.8.6 up to but not including 0.11.4 have a privilege escalation vulnerability in the terminal proxy. Authenticated users can exploit this flaw to access the Terminals administrator API using a shared key, allowing them to list or stop other users' terminals and modify terminal policies, including injecting environment variables into other users' terminals. This vulnerability is fixed in version 0.11.4.
References
- github.com/open-webui/open-webui/security/advisories/GHSA-q46m-r89w-j74p (opens in a new tab)
- github.com/open-webui/open-webui/commit/51bb8cb142f72503e861eeee25ae4dc73c26c36b (opens in a new tab)
- vulncheck.com/advisories/open-webui-0.8.6-before-0.11.4-privilege-escalation-via-terminal-proxy (opens in a new tab)