Skip to main content
VulnerabilityPublished

CVE-2026-10989: Google Chrome · Inappropriate Implementation

Affects Google ChromeSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 149.0.7827.53 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 149.0.7827.53
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Google Chrome to 149.0.7827.53.

Affected software

ProductAffectedFixed in
GoogleChromeAffected
  • >=149.0.7827.53 <149.0.7827.53
Fixed in
  • 149.0.7827.53

AI-suggested

The vendor advisory linked indicates a stable channel update for desktop Chrome, implying that version 149.0.7827.53 or later includes a fix. Users should update to Chrome version 149.0.7827.53 or later to remediate this vulnerability. Patch status is not explicitly confirmed in the advisory content provided, so users should verify the update status via the official Chrome release notes. No additional mitigation steps are specified.

Description

CVE-2026-10989 is a high-severity vulnerability in the V8 engine of Google Chrome prior to version 149.0.7827.53. It involves an inappropriate implementation that could allow a remote attacker to exploit heap corruption by convincing a user to perform specific UI gestures on a crafted HTML page. This vulnerability requires user interaction and affects confidentiality, integrity, and availability. The issue is tracked under CWE-122 (Heap-based Buffer Overflow).

References

Community reviews

Loading reviews…