Skip to main content
VulnerabilityPublished

CVE-2026-109987: PixelYourSite (WordPress plugin) · Cross-site Scripting

Affects PixelYourSite (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.2 High : upgrade to 11.4.3 soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.17.2
EPSS
0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 11.4.3, 12.6.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade PixelYourSite to 11.4.3; PixelYourSite Pro to 12.6.8.

Affected software

ProductAffectedFixed in
PixelYourSiteAffected
  • <11.4.3
Fixed in
  • 11.4.3
PixelYourSite ProAffected
  • <12.6.8
Fixed in
  • 12.6.8

AI-suggested

Upgrade PixelYourSite to version 11.4.3 or later and PixelYourSite Pro to version 12.6.8 or later. These versions include fixes that properly sanitize and escape cookie values before outputting them, eliminating the XSS vulnerability. No other mitigation is indicated by the vendor advisory.

Description

A Cross-Site Scripting (XSS) vulnerability exists in the PixelYourSite WordPress plugin versions before 11.4.3 and PixelYourSite Pro versions before 12.6.8. The flaw arises because the plugins do not sanitize and escape a cookie value before outputting it on the page. On sites using full-page caching, this allows unauthenticated attackers to inject malicious scripts into the cached page, which are then served to other visitors.

References

Community reviews

Loading reviews…