Skip to main content
VulnerabilityPublished

CVE-2026-109988: Product Addons for Woocommerce (WordPress plugin) · Cross-site Scripting

Affects Product Addons for Woocommerce (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 4.4 Medium.

Data as of 28 Oct 2026, 07:12 UTC

CVSS 3.1 base score
4.4Medium
How severe the flaw is on the 0–10 CVSS scale.
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
acowebsProduct Addons for Woocommerce – Product Options with Custom FieldsAffected
  • <=3.1.8
Fixed in–

AI-suggested

Users should upgrade beyond version 3.1.8 once a fixed version is released. Until then, restrict shop manager-level access to trusted users only and monitor for suspicious activity. Review plugin updates from the vendor for remediation.

Description

The Product Addons for Woocommerce – Product Options with Custom Fields WordPress plugin up to version 3.1.8 is vulnerable to a stored cross-site scripting (XSS) flaw. This vulnerability arises from insufficient input sanitization and output escaping of the 'fields[section][fields][row][col][type]' parameter. Authenticated users with shop manager-level privileges or higher can exploit this to inject malicious scripts that execute when other users view the affected pages.

References

Community reviews

Loading reviews…