CVE-2026-110024: @fastify/jwt · Insufficient Session Expiration
Affects @fastify/jwtSource CVE Database V5
Not known to be exploited · CVSS 6.8 Medium : upgrade to 10.2.5 when convenient.
Data as of 26 Oct 2026, 22:17 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Total control over the software or total information disclosure
CISA SSVC assessment, 2026-10-20.
- Patch
- Available – fixed in 10.2.5
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 18 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade @fastify/jwt to 10.2.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| @fastify/jwt@fastify/jwt | Affected
| Fixed in
|
npm@fastify/jwtpkg:npm/@fastify/jwtOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade @fastify/jwt to version 10.2.5 or later, where the issue is fixed. Users should avoid using the top-level sign and verify methods with per-call options that omit expiration settings until upgraded. Route-level decorators are not affected and can be used as a temporary workaround. No other mitigations are specified.
Description
@fastify/jwt versions prior to 10.2.5 have a vulnerability where the top-level sign and verify methods do not merge per-call options with global defaults. This causes token expiration and maximum age protections to be silently dropped, resulting in tokens that never expire and verification that does not enforce maximum age. The issue is fixed in version 10.2.5.