Skip to main content
VulnerabilityPublished

CVE-2026-110354: HAProxy · Infinite Loop

Affects HAProxySource CVE Database V5

0

Not known to be exploited · CVSS 7.5 High · fixed in 3.5-dev9 : patch HAProxy soon.

Data as of 26 Oct 2026, 17:30 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers can reliably automate steps 1–4 of the kill chain
Technical impact
Limited control over the software or limited information exposure

CISA SSVC assessment, 2026-10-22.

Patch
Available – fixed in 3.5-dev9, 3.4.6, 3.3.17 +9
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
HAProxyHAProxyAffected
  • >=3.5-dev <3.5-dev9
Fixed in
  • 3.5-dev9
HAProxyHAProxyAffected
  • >=3.4.0 <3.4.6
Fixed in
  • 3.4.6
HAProxyHAProxyAffected
  • >=3.3.0 <3.3.17
Fixed in
  • 3.3.17
HAProxyHAProxyAffected
  • >=3.2.0 <3.2.26
Fixed in
  • 3.2.26
HAProxyHAProxyAffected
  • >=3.0.0 <3.0.30
Fixed in
  • 3.0.30
HAProxyHAProxy Enterprise EditionAffected
  • >=3.3r1 <3.3r1-377.1005
Fixed in
  • 3.3r1-377.1005

AI-suggested

Upgrade HAProxy to one of the fixed versions: 3.4.6, 3.5-dev9, 3.3.17, 3.2.26, 3.0.30, or the corresponding patched releases in the 3.3r1, 3.2r1, and 3.0r1 branches. No other mitigations are indicated. Applying these official fixes fully resolves the issue.

Description

HAProxy versions prior to 3.4.6 contain an infinite loop vulnerability in the HTTP/1.1 chunked request parser. This flaw allows a remote unauthenticated attacker to cause a denial of service by exhausting CPU resources on worker threads. The affected threads remain at 100% CPU usage even after client disconnects and timeouts, potentially consuming all worker threads and requiring a process restart to recover.

References

Community reviews

Loading reviews…