CVE-2026-111379: FreeRDP · Heap-based Buffer Overflow
Affects FreeRDPSource CVE Database V5
Public exploit available · CVSS 7.0 High : upgrade to 3.32.0 as a priority.
Data as of 27 Oct 2026, 20:58 UTC
- CISA SSVC
- Exploitation
- Proof of concept is public or traded
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Total control over the software or total information disclosure
CISA SSVC assessment, 2026-10-16.
- Patch
- Available – fixed in 3.32.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
t = 0 is the CVE’s publication on cve.org
Disclosed: evidence found.
CVE published 16 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: evidence found.
CISA SSVC: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
Timeline
CVE ID reserved
by VulnCheck
, 3 hours before disclosure
CVE published
on cve.org
, t = 0
CISA SSVC assessment
proof of concept public
, 16 hours after disclosure
In Threat Radar
record ingested
, 11 days after disclosure
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA SSVC, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade FreeRDP and freerdp/FreeRDP to 3.32.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| FreeRDPFreeRDP | Affected
| Fixed in
|
GitHubfreerdp/FreeRDPpkg:github/freerdp/FreeRDPOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade FreeRDP to version 3.32.0 or later, where this heap buffer overflow vulnerability is fixed. No other mitigation or temporary workaround is indicated by the vendor advisory.
Description
FreeRDP versions prior to 3.32.0 contain a heap-based buffer overflow vulnerability in the persistent_cache_read_entry_v3 function. This flaw allows local attackers to supply a crafted v3 persistent cache file with large width and height values that cause size calculation wraparound, leading to an overflow of an undersized buffer during fread. Successful exploitation could result in memory corruption and potential code execution.