Skip to main content
VulnerabilityPublished

CVE-2026-1115: parisneo/lollms · Cross-site Scripting

Affects parisneo/lollmsSource CVE Database V5

0
Compare

Not known to be exploited · public detection template (Nuclei) · CVSS 9.6 Critical : upgrade to 2.2.0 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.0 base score
9.6Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.2% chance of exploitation in 30 days – higher than 69% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.2.0
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Apr 2026

  2. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade parisneo/lollms to 2.2.0.

Affected software

ProductAffectedFixed in
parisneoparisneo/lollmsAffected
  • ≥ unspecified, < 2.2.0
Fixed in–
GitHubparisneo/lollmspkg:github/parisneo/lollmsOther threatsAffected
  • <2.2.0
Fixed in
  • 2.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to parisneo/lollms version 2.2.0 or later, where this vulnerability has been fixed by properly sanitizing user input in the create_post function. Since this is an application-level vulnerability and not a cloud service, applying the official patch is necessary to remediate the risk. Patch status is confirmed fixed in version 2.2.0.

Description

CVE-2026-1115 is a critical stored Cross-Site Scripting (XSS) vulnerability in the social feature of the parisneo/lollms application prior to version 2.2.0. The flaw exists in the create_post function where user input is stored without proper sanitization, allowing malicious JavaScript to be injected and executed in the browsers of users viewing the Home Feed, including administrators. This can lead to severe impacts such as account takeover, session hijacking, and wormable attacks. The vulnerability is resolved in version 2.2.0.

References

Community reviews

Loading reviews…