CVE-2026-111585: TeamViewer Full Client · Integer Overflow or Wraparound
Affects TeamViewer Full ClientSource CVE Database V5
Not known to be exploited · CVSS 8.8 High · fixed in 15.83 : patch TeamViewer Full Client soon.
Data as of 27 Oct 2026, 15:42 UTC
- Patch
- Available – fixed in 15.83, 15.64.10 (Legacy Windows 7 & 8), 14.7.48868 (Windows) +5
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| TeamViewerFull Client | Affected
| Fixed in
|
| TeamViewerPortable | Affected
| Fixed in
|
| TeamViewerRemote Control | Affected
| Fixed in
|
AI-suggested
Upgrade TeamViewer Full Client, Portable, and Remote Control App to version 15.83 or later. For legacy Windows 7 and 8 systems, update to version 15.64.10. Other fixed versions include 14.7.48868 for Windows, macOS, and Linux, and 13.2.154008 (Linux), 13.2.154007 (macOS), and 13.2.36231 (Windows). Applying these updates will remediate the vulnerability.
Description
CVE-2026-111585 is an integer overflow vulnerability in the remote-control screen processing component of TeamViewer Full Client, Portable, and Remote Control App versions prior to 15.83. A malicious remote host could exploit this flaw to cause denial of service or potentially execute arbitrary code with the privileges of the viewer process. Exploitation requires a user to initiate a remote-control session to an attacker-controlled or compromised host. The vulnerability has a high severity with a CVSS score of 8.8 and has been fixed in version 15.83 and several legacy versions.