Skip to main content
VulnerabilityPublished

CVE-2026-111809: Apache Traffic Server · HTTP Request/Response Smuggling

Affects Apache Traffic ServerSource CVE Database V5

0

Not known to be exploited · CVSS 9.3 Critical.

Data as of 26 Oct 2026, 14:18 UTC

CVSS 3.1 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Traffic ServerAffected
  • >=8.0.0 <=8.1.11
  • >=9.0.0 <=9.2.15
  • >=10.0.0 <=10.1.4
  • =10.2.0
Fixed in–

AI-suggested

Users should upgrade Apache Traffic Server to versions 9.2.16, 10.1.5, or 10.2.1, which contain official fixes for this vulnerability. Applying these updates will remediate the inconsistent HTTP request interpretation and prevent request smuggling attacks. No other mitigations are specified.

Description

Apache Traffic Server versions 8.0.0 through 8.1.11, 9.0.0 through 9.2.15, 10.0.0 through 10.1.4, and 10.2.0 are vulnerable to HTTP request smuggling via HEAD requests that include Content-Length or Transfer-Encoding headers. This vulnerability is identified as CWE-444, involving inconsistent interpretation of HTTP requests. The issue allows attackers to interfere with request processing, potentially leading to information disclosure and request manipulation. Upgrading to versions 9.2.16, 10.1.5, or 10.2.1 addresses this vulnerability.

References

Community reviews

Loading reviews…