Skip to main content
VulnerabilityPublished Updated

CVE-2026-111927: coder · Insufficiently Protected Credentials

Affects coderSource CVE Database V5

0

Not known to be exploited · CVSS 8.7 High : upgrade to 2.35.4 soon.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Total control over the software or total information disclosure

CISA SSVC assessment, 2026-10-21.

Patch
Available – fixed in 2.35.4, 2.34.8, 2.33.12 +1
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:P/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
codercoderAffected
  • >=2.35.0 <2.35.4
Fixed in
  • 2.35.4
codercoderAffected
  • >=2.34.0 <2.34.8
Fixed in
  • 2.34.8
codercoderAffected
  • >=2.33.0 <2.33.12
Fixed in
  • 2.33.12
codercoderAffected
  • <2.29.20
Fixed in
  • 2.29.20
Gocoderpkg:golang/coderOther threatsAffected
  • >=2.35.0 <2.35.4
  • >=2.34.0 <2.34.8
  • >=2.33.0 <2.33.12
  • <2.29.20
Fixed in
  • 2.35.4
  • 2.34.8
  • 2.33.12
  • 2.29.20

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Coder before 2.29.20, 2.33.0 before 2.33.12, 2.34.0 before 2.34.8, and 2.35.0 before 2.35.4 contains an improper hostname validation flaw in GetWorkspaceProxyByHostname whose SIMILAR TO pattern performs a prefix match, so any domain that is a string prefix of a workspace-proxy access URL is trusted as a proxy. Attackers owning such a domain can lure an authenticated victim to a crafted /api/v2/applications/auth-redirect link, capture the redirected application_connect API key, and replay it to access the victim's workspace apps.

References

Community reviews

Loading reviews…